Resolved: EdgeManager service has been restored in the US-West environment.
Incident Report for Predix
Resolved

As of 3:37 PM PT, the Edge Manager device enrollment functionality has been restored in US-West and it's fully functional, users will be able to enroll new Edge devices.

Posted Jun 07, 2018 - 15:49 PDT
Investigating

Edge Manager, device enrollment functionality is in degraded state, users will experience errors while trying to enroll edge devices, root cause has been identified and engineering is working on the resolution.

Posted Jun 07, 2018 - 14:31 PDT
This incident affected: US-West Prod (EdgeManager).