Resolved: Predix Cache service has been recovered in the US-West environment.
Incident Report for Predix
Resolved

As of 16:05 PT, The Predix Cache service has been restored and it's fully functional, users should be able to create new instances without seeing any error.

Posted Feb 20, 2018 - 16:11 PST
Investigating

Users in US-West will not be able to create predix-cache service using the Dedicated plans, current instances are not impacted and they are working correctly 

Posted Feb 20, 2018 - 14:41 PST