Predix.io service is available in a degraded state in the AWS-US-West-Portland environment.
Incident Report for Predix
Resolved

The registration services have been restored and the users should be able to access the services normally.

Posted May 20, 2018 - 17:02 PDT
Update

Technical teams have identified the source of the issue and they are working on restoring the service. Next update will be available at 6:30 PM PT, 20 May 2018. 

Posted May 19, 2018 - 23:38 PDT
Update

Technical teams have identified the source of the issue and they are working on restoring the service.

Posted May 19, 2018 - 22:07 PDT
Investigating

The Predix.io user page currently unavailable for new user registration. Technical teams are actively troubleshooting this issue. 

Posted May 19, 2018 - 20:53 PDT